PodPress plugin

Update: The PodPress plugin is no longer being supported and is not compatible with WordPress 2.5+.  We recommend using the Podcasting plugin which was developed during the Google summer of code.

The PodPress plugin for WordPress does everything you need for podcasting. The quick-loading flash player is a great way for visitors to listen to (or watch) your podcasts and the iTunes integration really simplifies the whole submission and management process.

This plugin is updated with new features VERY often and continues to improve almost daily.
To find out more about the PodPress plugin for WordPress please visit Mighty Seek >>

Leave a Comment